Chyby #DIV/0! ve vzorcích

Pro informace o výuce Excelu klikněte zde

Tuto chybu vrátí vzorec, ve kterém se pokusíme dělit nulou.

Máte tabulku, kde počítáme rozdíl mezi hodnotami ve sloupci B a C

Do buňky D2 zadáme tento vzorec: =(C2-B2)/C2 a zkopírujeme směrem dolů

Pokud ale nemáme v některých buňkách sloupce C vložena data, vzorec vrátí chybu #DIV/0!

Řešení 1 (nedoporučené)

Označíme oblast buněk D2:D5, pomocí příkazu Formát – Podmíněné formátování do podmínky vzorce zadáme tento vzorec: =JE.CHYBA(D2) a nastavíme barvu písma jako se barva pozadí.

Po aplikování podmíněného formátování již chybové hodnoty nevidíme.

Ale stále v buňkách jsou.

Nesmíme měnit barvu pozadí, ani se na tyto buňky odkazovat v dalších vzorcích, protože nám zobrazí chybovou hodnotu.

Proto je lepší použít funkci KDYŽ viz. řešení 2

Řešení 2 (doporučené)

Řešení spočívá v otestování hodnoty v buňce, zda je prázdná pomocí funkce KDYŽ

Do buňky D2 zadáme tento vzorec: =KDYŽ(JE.PRÁZDNÉ(C2);””;(C2-B2)/C2) a zkopírujeme směrem dolů

Pokud je buňka prázdná, vzorec vrátí prázdný řetězec.

Tento postup nám bude fungovat, jen když budou buňky ve sloupci C prázdné. Pokud budeme mít ve sloupci C vzorce, které vrací hodnotu 0, nebo hodnotu 0 zadáme do buňky přímo, tak už buňka nebude prázdná a dělení se uskuteční.

V tom případě zadáme do buňky D2 tento vzorec: =KDYŽ(NEBO(JE.PRÁZDNÉ(C2);C2=0);””;(C2-B2)/C2) a zkopírujeme směrem dolů. Funkce NEBO nám otestuje, zda je buňka prázdná i zda neobsahuje hodnotu 0.

V posledním případě zadáme do buňky D2 tento vzorec: =KDYŽ(JE.CHYBA((C2-B2)/C2);””;(C2-B2)/C2) a zkopírujeme směrem dolů. Tento vzorec nám pomocí funkce JE.CHYBA testuje vzorec (C2-B2)/C2, zda vrací chybu. Ale potom nezjistíme, zda nám vzorec nevrací chybu z jiného důvodu.

Napsat komentář

Vaše emailová adresa nebude zveřejněna. Vyžadované informace jsou označeny *