Chyby #N/A ve vzorcích

Pro informace o výuce Excelu klikněte zde

K této chybě dochází ze dvou důvodů

1. K chybě dochází, když jakákoli buňka v oblasti na kterou se odkazuje vzorec zobrazuje #NA

2. K chybě dochází, když vyhledávací funkce (VVYHLEDAT, SVYHLEDAT, VYHLEDAT, POZVYHLEDAT) nenajde žádnou hodnotu.

Máte tabulku se seznamem norem (sloupce A a B) a v buňce F1 vzorec, který hledá k hodnotě zadané do buňky E1 příslušný název.

Pokud do buňky E1 zadáme normu, která není v seznamu, dostaneme chybu #N/A, která nám říká, že vyhledávací funkce nenalezla žádnou shodu.

Řešení 1

Místo původního vzorce

=SVYHLEDAT(E1;A1:B5;2;0)

použijeme vzorec ve tvaru

=KDYŽ(JE.NEDEF(SVYHLEDAT(E1;A1:B5;2;0));”Nenalezeno”;SVYHLEDAT(E1;A1:B5;2;0))

tj. použijeme funkci JE.NEDEF – vrátí nám hodnotu PRAVDA (pokud vyhledávací funkce vrací #N/A), nebo NEPRAVDA, kterou otestujeme funkcí KDYŽ

Řešení 2

Místo původního vzorce

=SVYHLEDAT(E1;A1:B5;2;0)

použijeme vzorec ve tvaru

=KDYŽ(COUNTIF(A1:B5;E1)=0;”Nenalezeno”;SVYHLEDAT(E1;A1:B5;2;0))

tj. použijeme funkci COUNTIF pro zjištění počtu výskytů hledané hodnoty, zda není počet roven 0

Napsat komentář

Vaše emailová adresa nebude zveřejněna. Vyžadované informace jsou označeny *