Počet buněk dle velikosti písma

Pro informace o výuce Excelu klikněte zde

Pokud chceme spočítat buňky v oblasti splňující zadané kritérium, použijeme funkci COUNTIF. Funkce ale nerozlišuje velikost písma. Pokud chceme spočítat buňky v oblasti splňující kritérium i podle velikosti písma můžeme použít maticové vzorce. Např.:

Počet buněk, které obsahují jedno písmeno a to malé d
{=SUMA(STEJNÉ($A$2:$A$9;”d”)*1)}

Počet buněk, které obsahují jedno písmeno a to velké D
{=SUMA(STEJNÉ($A$2:$A$9;”D”)*1)}

Počet buněk, které začínají na malé d
{=SUMA(STEJNÉ(ZLEVA($A$2:$A$9;1);”d”)*1)}

Počet buněk, které začínají na velké D
{=SUMA(STEJNÉ(ZLEVA($A$2:$A$9;1);”D”)*1)}

Počet buněk, které začínají malým písmem
{=SUMA(STEJNÉ(ZLEVA($A$2:$A$9;1);MALÁ(ZLEVA($A$2:$A$9;1)))*1)}

Počet buněk, které začínají velkým písmem
{=SUMA(STEJNÉ(ZLEVA($A$2:$A$9;1);VELKÁ(ZLEVA($A$2:$A$9;1)))*1)}

Počet všech malých d v oblasti
{=SUMA(DÉLKA($A$2:$A$9)-DÉLKA(DOSADIT($A$2:$A$9;”d”;””)))}

Počet buněk, které obsahují malé da
{=SUMA(KDYŽ(JE.CHYBA(NAJÍT(“da”;$A$2:$A$9));;1))}

Pozn.: Závorky {} na začátku a na konci se u maticových vzorců nepíšou, ale zadávají se pomocí kl. zkratky CTRL+SHIFT+ENTER

Napsat komentář

Vaše emailová adresa nebude zveřejněna. Vyžadované informace jsou označeny *