Porovnávání hodnot

Pro informace o výuce Excelu klikněte zde

Dotaz:

Dobrý den,

obracím se na Vás s prosbou o pomoc s řešením. Prohlédl jsem si různé řešené příklady na Vašem webu i jinde, ale nějak to nemohu napasovat na můj požadavek.Porovnávají se hodnoty na listu “overovacidata” se sloupcem KOD, který je vztažen vždy ke stejnému datumu se stejným RC a UZ. V případě, že nenalezne shodu alespoň v jednom případě, vykopírovat řádek-y ( zvýrazněné tučně ) na aktivní, nebo nový list.

Tabulka:

Hodnoty na listu “overovacidata”

Řešení:

Pro lepší čitelnost vzorce si můžeme vytvořit pojmenovanou oblast over

Do buňky E2 zadáme maticový vzorec
{=SUMA(KDYŽ(($A$2:$A$16&$B$2:$B$16&$C$2:$C$16=A2&B2&C2);COUNTIF(over;$D$2:$D$16)))}
a zkopírujeme do oblasti E2:E16

Pozn.: Závorky {} na začátku a na konci se u maticových vzorců nepíšou, ale zadávají se pomocí kl. zkratky CTRL+SHIFT+ENTER

Výsledek:

Vytvoříme si nový list s  s názvem “porovnání” pro vykopírování řádků splňující podmínku (hodnota 0) pomocí rozšířeného filtru. Oblast kritérií zadáme do buněk A1:A2

Spustíme rozšířený filtr – Data – Filtr – Rozšířený filtr, nastavíme oblast seznamu, oblast kritérií a kopírovat do.

Výsledek:

2 komentáře

  1. Dobrý den, dovoluji si požádat Vás o radu. Mám-li v excelu dva listy, v jednom je určité množství dat, vyplněných buněk, v druhém jsou stejná data jako v prvním a zároveň jich je tam ještě mnohem víc, řádově o několik set. Mám možnost nějakým postupem zjistit, která data jsou v druhém sešitu navíc oproti sešitu prvnímu?

  2. Dobrý den, neznám přesný tvar Vašich dat, ale většinou lze s úspěchem použít funkci COUNTIF, případně vyhledávací funkce.

Napsat komentář

Vaše emailová adresa nebude zveřejněna. Vyžadované informace jsou označeny *