Sčítání položek za jednotlivé týdny

Pro informace o výuce Excelu klikněte zde

Dotaz:

Zdravím. Potřeboval bych píchnout s vyřešením problému sčítání položek za jednotlivé týdny.

Máme tabulku s následujícími daty:

Kde ve sloupci A jsou datumy a ve vedlejším sloupci B hodiny které chceme sečíst.

1. Řešení pomocí funkce SOUČIN.SKALÁRNÍ:

Vytvoříme pomocnou tabulku, kde zadáme datumy od do

Do buňky F2 zadáme tento vzorec a zkopírujeme dolů:

=SOUČIN.SKALÁRNÍ(($A$2:$A$36>=D2)*($A$2:$A$36<=E2)*$B$2:$B$36)

Výsledek:

Pozor! Při sčítání hodnot obsahující čas a  přesahující 24 hodin musíme nastavit Formát buněk – Číslo – Vlastní na  [h]:mm (kód “h” mezi hranaté závorky [] )

V opačném případě uvidíme např. místo hodnoty 110:45 hodnotu 14:45 (Excel provede konverzi na 24 hodinový cyklus)

Alternativně můžeme použít formát d -h:mm při kterém uvidíme místo hodnoty 110:45 hodnotu 4 – 14:45 tj. 4 dny, 14 hodin a 45 minut.

2. Řešení pomocí kontingenční tabulky:

Spustíme průvodce kontingenční tabulkou – Data – Kontingenční tabulka a graf…

V kroku 2 určíme oblast dat, které chceme zpracovat

V posledním kroku určíme umístění kontingenční tabulky a použijeme volbu Rozvržení…

A z pravé strany přetáhneme Datum do Řádkového pole, Hodiny přetáhneme do Datového pole. Poklepáním na položku Hodiny v datovém poli změníme Souhrny na Součet a dále nesmíme zapomenout nastavit formát čísla na [h]:mm

Nakonec potvrdíme OK a dáme Dokončit.

Mezivýsledek:

Potom buňkový kurzor postavíme na libovolnou buňku obsahující datum a zadáme příkaz Data – Skupina a přehled – Seskupit

V zobrazeném dialogovém okně provedeme nastavení dle obrázku.

Výsledek:

Napsat komentář

Vaše emailová adresa nebude zveřejněna. Vyžadované informace jsou označeny *