Sčítání sloupců ob jeden dle kritéria

Pro informace o výuce Excelu klikněte zde

Dotaz:
Ahoj
obracím se na vzorečkáře, byl jsem dotázán, zda lze sčítat sloupce ob jeden dle kriteria v předchozím sloupci, za každý řádek
V reálu to vypadá následovně
Mam 10 sloupečků v sloupci 1,3,5,7,9 jsou kriteria a ve sloupcích 2,4,6,8,10 jsou hodnoty.
Zadaní je takové
Najdi ve sloupcích 1,3,5,7,9 číslo 1 (to tam může byt jen jednou, ale v kterémkoliv sloupci) a vem hodnotu ze sloupce vedle.
Tzn. hodnota 1 je ve sloupci 3, zpátky dostanu výsledek ze sloupce 4Mam to počítat pro 5 hodnot

Tabulka:

Do buňky L2 zadáme maticový vzorec
{=SUMA(KDYŽ((ZLEVA($B$1:$J$1;3)=”Kri”)*($B2:$J2=L$1);POSUN($B2:$J2;0;1)))}
a zkopírujeme do oblasti L2:P11

Pozn.: Závorky {} na začátku a na konci se u maticových vzorců nepíšou, ale zadávají se pomocí kl. zkratky CTRL+SHIFT+ENTER

Výsledek:

Tento vzorec hledá v oblasti B1:J13 shodu počátečních tří písmen (ZLEVA($B$1:$J$1;3)=”Kri”), dále hledá shodu kritérií ($B2:$J2=L$1), pokud jsou obě podmínky splněny, vrací hodnotu sousední buňky vpravo POSUN($B2:$J2;0;1)

Další z možných řešení:

Předchozí vzorec hledal shodu počátečních tří písmen, ale máme-li kritéria v lichých sloupcích oblasti, můžeme použít podmínku (MOD(SLOUPEC($B:$J)-1;2)=1), pokud ještě použijeme funkci SOUČIN.SKALÁRNÍ vynecháme funkci KDYŽ. Výsledný vzorec:

=SOUČIN.SKALÁRNÍ((MOD(SLOUPEC($B:$J)-1;2)=1)*($B2:$J2=L$1)*POSUN($B2:$J2;0;1))

Případně místo násobení použít dvojici unárních operátorů (–)

=SOUČIN.SKALÁRNÍ(–(MOD(SLOUPEC($B:$J)-1;2)=1);–($B2:$J2=L$1);–(POSUN($B2:$J2;0;1)))

Napsat komentář

Vaše emailová adresa nebude zveřejněna. Vyžadované informace jsou označeny *